snowflake/home/profiles/tsuki/stylix.nix
notohh fa909a2d6f
All checks were successful
ci/woodpecker/cron/flake-lock-update Pipeline was successful
flake.lock: update
firefox: update betterfox

tsuki: add bolt launcher

stylix: disable zellij

yuki: remove twitch miner

yuki: remove twitch miner

pgres: init ec db

yuki: bump docker versions

tsuki: disable waydroid

default: disable helix

default: update default editor

firefox: edit extensions

torrent: bump qbit

services: remove wlsunset
2024-11-12 16:44:37 -05:00

53 lines
1.1 KiB
Nix

{
inputs,
pkgs,
...
}: {
imports = [inputs.stylix.homeManagerModules.stylix];
stylix = {
enable = true;
autoEnable = false;
polarity = "dark";
base16Scheme = "${pkgs.base16-schemes}/share/themes/tokyo-night-dark.yaml";
fonts = {
monospace = {
name = "JetBrainsMono NF Medium";
package = pkgs.nerdfonts;
};
serif = {
name = "Noto Serif";
package = pkgs.noto-fonts;
};
sansSerif = {
name = "Noto Sans";
package = pkgs.noto-fonts;
};
emoji = {
name = "Twitter Color Emoji";
package = pkgs.twitter-color-emoji;
};
sizes = {
applications = 10;
desktop = 10;
popups = 10;
terminal = 12;
};
};
cursor = {
name = "Bibata-Modern-Classic";
package = pkgs.bibata-cursors;
size = 24;
};
opacity = {
terminal = 0.6;
};
targets = {
mako.enable = true;
lazygit.enable = true;
nushell.enable = true;
yazi.enable = true;
bat.enable = true;
};
};
}